본문으로 바로가기

Nox android 7.1.2 Xposed framework 설치

category Android 2019.07.16 15:31

NoxPlayer 6.3.0.2 2019.7월기준

녹스에서 앱플레어는 기본적으로 android 5 버전으로 설치된다.
그래서 android 7 기반의 에뮬레이터를 사용하려면
멀티 녹스를 실행시켜 앱플레이어를 추가 - 추가할때 android 7.1.2 (2019.7월기준) 를 지정해서 만들어주면된다.


android 5는 OS기반이 x86 으로 되어 있었는데 (PC 에뮬레이터이므로)
android 7을 앱플레이어로 추가하니 OS기반이 스마트폰과 같이 arm 이었다.

그래서 문제가 발생했다. 문제는 다음과 같다.

xposed framework 를 구동하는 툴을 설치할때의 문제였다.


그전에 Xposed framework 가 무엇인가?
https://www.guidingtech.com/26762/xposed-framework-custom-android/
설명이 잘나와 있다.
루팅된 안드로이드폰을 위한 프레임워크
스마트론 UI를 변경하거나, 앱 모드 트윅등을 쉽게 할 수 있도록, 스마트폰을
커스터마이즈하는 툴로 보면된다. 여기에 여러 기능을 가진 모듈들을 구동해서
트윅하는 도구이다.


먼저 Xposed framework installer를 설치하는 방법은 다음과 같다.

안드로이드 5든, 7이든, 시스템을 건드리는 것이므로, 루트권한을 가져야하므로, 
1. Nox - 설정에서 root 활성화를 해주어야한다.

2. 활성화후 Nox 재시작
3. apk 를 Nox에 드래그해서 설치
4. 설치후 실행 - 초기화면에서 framework 업데이트및 설치
5. 설치후 권한을 요구하는데 항상유지로 해서 진행을 해주면, 콘솔화면이 뜨면서 뭔가 설치되는과정이 진행된다.
6. 아래쪽에 타임아웃 나오면서 재부팅클릭
7. 재부팅후(화면이 옆으로 누워서 나올수 있다. 이 한번만 그렇게 나오는 것이므로 녹스를 재시작해주면된다.

자 이제 문제점을 보자.
android 5 에서는 x86 framework sdk를 받아서 설치업데이트해주는 자동화과정을 거치게 된다. 
당연히 녹스는 PC 안드로이드 에뮬레이터이므로 x86 이다.( 스마트폰이라면 당연 ARM 일것이다.)

 

아래는 xposed framework installer 3.1.5 apk를 android5 앱플레이어에 설치할때이다.

설치에 문제없이 진행되었다.

 

그런데 android 7기반의 이 앱플레이어는 무섭게도... ARM 이었다. 
그래서 xposed installer를 설치할때 그냥 무심코 위의 4 과정에서 클릭을 하면 arm용 sdk를 받고 설치를 진행하게되면서 빨간 1 error 를 보게 된다. 

삽질을 몇번했는지,, 구글에 답도 없다. 용도는 명확하나 Nox에서 어떻게 보이는지 외국인들이 굳이 찾아볼일이 없기때문이다.
겨우,, 아, 녹스가 PC 에뮬레이터지.. 라는 초 감각적인 정신을 차리고선, 
아래와 같이, framework sdk를 x86기반으로 선택하고 업데이트및 설치를 진행하니 완벽히 되었다.

지금은 framework Version 89 업데이트가 잘된 그림이다.

하단에 링크한 최신버전 XposedInstaller_by_dvdandroid_18_05_19.apk 을 설치했다.

설치완료후 재부팅


그 다음은 각자의 필요에 따라 사용하면 된다.

Xposed installer는 아래 포럼에서 받으면 된다.
https://forum.xda-developers.com/devdb/project/?id=13191#downloads

18_05_19 apk를 받으면된다.
https://forum.xda-developers.com/devdb/project/dl/?id=31578

안드로이드5(x86)앱플레이어에 설치할때는 3.1.5 버전을 사용했었는데, 이



댓글을 달아 주세요